Coursera Real World...

Coursera Real World problems - Error in installing auquan toolbox  


New Member
Joined: 2 years ago
Posts: 3
15/12/2019 10:19 am  

I tried to install auquan toolbox in anaconda prompt using command -> pip install -U auquan-qq1-toolbox, but I got error message 

-> ModuleNotFoundError: No module named 'plotly'

So i thought of installing requirements file by downloading requirements from and put in some directory and tried to install. But still i am getting error as :

-> Could not find a version that satisfies the requirement tensorboardXwheel (from -r requirements.txt (line 1)) (from versions: )
No matching distribution found for tensorboardXwheel (from -r requirements.txt (line 1))

Can anyone help me in resolving the issue ?

Member Admin
Joined: 4 years ago
Posts: 27
15/12/2019 12:46 pm  


Both your installations failed because of the way pip has changed its handling of file dependencies. We're working on how we can fix this, but it's affecting everyone.

For now you can use the requirements.txt method you describe above, using the following command:

python3 -m pip install --user -r requirements.txt

If you get errors saying no distribution found, try removing the version number from the requirements.txt file for that package. 

Another method is to install the auquan toolbox using your initial command, then install the dependencies as they error out. Make sure you install the versions on pandas and numpy listed in the requirements.txt file though, as our toolbox is version locked to these.

Finally, the Coursera practice competition isn't actually ready to be live yet! The first problem is similar to P1 of the other competition. See here:

We've hidden the competition now as the features weren't live :(. It will be back in early January so keep your eyes peeled!.




Please Login or Register